Showing results for 
Search instead for 
Did you mean: 

Dashboard filter not affecting Table type widget

9 - Travel Pro
9 - Travel Pro

I need some assistance here.  I know I am missing some small obvious thing but can't for the life of me see it.

I have a table in my cube that is an MS SQL data table.  I have a custom query to select this data that returns 5 columns, 3 alpha, 1 date (not datetime), and 1 numeric (0 or 1).  This table has no associations to any other table in the cube.

I created a new dashboard then created a new widget on that dashboard.  The widget is a Table widget that displays these 5 columns from the table in the cube.  So far, so good.  The widget displays all of the rows from the table.

Next I added a dashboard filter on the numeric column.  The filter "List" correctly shows that there are only two values; 0 and 1.  On the widget, the dashboard filters are turned on.  However, when I change the dashboard filter to only show rows with a 1 in the numeric column, the widget thinks (... wait cursor) and then displays all rows in the table.  It does not filter out the rows with a 0 in the numeric column.  I have tried with a filter on the Date column as well as a filter on one of the alpha columns.  They all behave the same.  All rows are shown regardless of the value of the filters.

I have verified that the columns the filters are pointed to are the same columns being displayed in the widget.

I tried putting the filters on the widget rather than the dashboard to no avail.

I do have row level security set up on the Data cube but this particular table isn't tied into that at all.  If that was a problem I would expect that no rows would be returned but, as it is, all rows are being returned.

Like I said, I know I am just missing something obvious but am not seeing what it is.  This seems like such a trivial task.  Any ideas would be greatly appreciated.


9 - Travel Pro
9 - Travel Pro

Try verifying that the filter behavior of the widget is set to "slice/filter" rather than "highlight" it may be that the rows you're filtering to are simply being highlighted and are not in the current view of the table, making it seem like nothing happened.

From the widget filter panel, select "slice/filter":



Hi @sneak,

Thanks for your response.  As I have been bitten by this before, it was one of the first things I checked.  However, it appears that this option isn't even available for a table widget.