Showing results for 
Search instead for 
Did you mean: 
Community Team Member
Community Team Member
Just after a clean (new) install of Sisense or after an upgrade, you may in rare cases run into the following error on the Data Sources page within the Web ElastiCube Manager (ECM 2.0):
Unable to reach the Sisense Server, please ensure you are connected to the internet. If the connection is fine, please contact your administrator as there may be a problem on the server side.


Some of the symptoms related to this error are:
http://localhost:8081/app/test returns false for IIS
Can't see cubes in the Data tab in Sisense Web as the SysAdmin
Especially if you have cubes existing within the Desktop ECM (ECM 1.0)
Not able to create cubes in Sisense Web
You may also see an error such as "Unexpected token a in JSON at position 0"


To Resolve this issue, please do the following:

If /app/test page returns false for IIS: Enable IIS on your machine

These instructions will differ depending on whether Sisense is running on a desktop/laptop computer versus a server.

On a Server

Go to Control Panel > Turn Windows features on or off
Server Manager will appear and Add Roles and Features Wizard will pop up
On the Before You Begin page, Click next
On the Installation Type page select Role-Based or feature-based installation, Click next
On the Server Selection page, make sure your server is selected, Click next
On the Server Roles page, make sure Web Server (IIS) is checked. The exact features don't seem to matter as much. It is safest to enable all features for IIS but bare minimum we need the roles selected below. Then click Next
On the Features page, we need to have the following features enabled. Definitely need .NET 4.5, don't really need .NET 3.5. Each time you select a feature you may see a popup like shown below. Click Add Features. 
Once all features required are added, Click Next
On the Confirmation Page, click install.
Once the install is done, do an IIS reset and then restart the server so that the changes take effect.

On a Personal Computer

It might be that the customer's machine is lacking essential components of the IIS.
On the computer, go to "turn Windows features on or off":
Then, look for "Internet Information Services", and make sure that all of the components which are checked on your machine are checked on the machine. 
After checking each of these options, restart your computer and try loading the Sisense website again.
Version history
Last update:
‎03-02-2023 09:44 AM
Updated by:
Community Toolbox

Recommended quick links to assist you in optimizing your community experience:

Developers Group:

Product Feedback Forum:

Need additional support?:

Submit a Support Request

The Legal Stuff

Have a question about the Sisense Community?

Email [email protected]

Share this page: