Knowledge Base Article

Troubleshooting Windows Authentication Login to SQL Server

Symptom

You can connect to the server and preview is showing data, but the build process fails due to connectivity issues.

Cause

The ElastiCube server service is running on the system account, but not on the logged on user’s account.

Solution

For Sisense version < 7.2:
Change the logon properties of the ElastiCube Management Service.
For Sisense version >= 7.2:
Change the logon properties of the Sisense.ECMS and Sisense.ECMServer services.
Steps:
  1. Go to Control Panel > Administrative Tools > Services
  2. Find ElastiCube Management Service, right-click and select Stop.
  3. Find ElastiCube Management Service, right-click and select Properties.
  4. Select the Log On tab, select This Account then click Browse.
    ecubetroubleshoot1.png
  5. Click Locations.
    ecubetroubleshoot2.png
  6. Choose your domain (e.g., Sisense.local in this example) and click OK.
    ecubetroubleshoot3.png
  7. Click Advanced.
    ecubetroubleshoot4.png
  8. Click Find Now, choose the user logged on to the machine and click OK.
    ecubetroubleshoot5.png
  9. The selected user will be added to the names box, click OK.
    ecubetroubleshoot6.png
  10. Enter and verify the user’s password, click OK.
    ecubetroubleshoot7.png
  11. Restart the service.
Updated 03-02-2023
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