cancel
Showing results for 
Search instead for 
Did you mean: 
intapiuser
Community Team Member
Community Team Member

Connecting to Oracle DB with Service Name (instead of Service ID - SID)

When a customer tries to connect to an Oracle DB using a Direct Connection option, there's no option in the GUI in the ElastiCube Manager to use a Service Name, only a Service ID:

 

jcordell_0-1674146460268.png

 

Solution

1) Uncheck the Use Direct Connection checkbox.

2) In the Database server location textbox, enter the following:

(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=$your_ip)(PORT=$your_port))(CONNECT_DATA=(SERVICE_NAME=$service_name)))

The variables you need to input are:

  • $your_ip
  • $your_port
  • $service_name

3) Connect to the source.

Version history
Last update:
‎01-19-2023 08:43 AM
Updated by:
Community Toolbox

Recommended quick links to assist you in optimizing your community experience:

Need additional support?:

Community Support Request