cancel
Showing results for 
Search instead for 
Did you mean: 

Is there a way to pass specific filters for Jump to Dashboard?

hkkwon89
9 - Travel Pro
9 - Travel Pro

I have a pivot table with a few columns with JTD enable to another dashboard.

hkkwon89_0-1661551581432.png

However, I want the OldestNoteDateofVisit column to not pass as a filter.

Is it possible to exclude specific column to be passed as a filter in JTD?

1 ACCEPTED SOLUTION

Hi Sneak,

It looks like you missed space in the dimension. The correct form is below:

[NOTES.OldestNoteDateOfVisit (Calendar)]

Another point - type of the variable "excludeFilterDims" is "array". So, the whole script will look like this:

prism.jumpToDashboard(widget, {
  excludeFilterDims: [
    "[NOTES.OldestNoteDateOfVisit (Calendar)]"
  ]
}

 

View solution in original post

8 REPLIES 8

sneak
8 - Cloud Apps
8 - Cloud Apps

Yes, you’re looking for the excludeFilterDims option, which can be set in the widget script of the source widget. For example:

 

prism.jumpToDashboard(widget, { excludeFilterDims:"[table_name.column_name]"});

 

I think the syntax is right, but I can’t actually test right this minute. May need to play around with the quotes and brackets around the table and column name. Let me know if you can’t get it to work and I’ll pull one of the working examples I have.

There are a lot of other useful options you can set in the source widget script as well, such as hiding certain panes, changing the type of JTD (pop up vs. new tab vs. new window), etc. You can see some of those details here (though the examples aren’t very thorough): https://www.sisense.com/marketplace/jump-to-dashboard/ (under the “Technical Details” tab). 

Hope this helps! Write back and let us know if the syntax is correct or needs to be adjsuted for the excludeFilterDims option

Hi @sneak ,

Thanks for your reply. I did try that route as well but it did not work for me.

I am pasting the script I have below.

 

prism.jumpToDashboard(widget, {
drilledDashboardDisplayType:1,
displayFilterPane:true,
excludeFilterDims:["[NOTES.OldestNoteDateOfVisit]"],
displayDashboardsPane:false,
displayToolbarRow:false,
displayHeaderRow:false,
drillToDashboardNavigateType:1,
dashboardId:"62fd12cc9162f000395da2cc"
});

Thank you

Hi @hkkwon89,

Yeah, I’ve battled with this before as well, like I mentioned. I went to pull a working example, and the problem is with syntax. In this case, since you are only excluding one filter, you don’t need to leading bracket (that’s only for cases where you are going to list multiple dimensions to exclude).

So, update your script to look like this:

prism.jumpToDashboard(widget, {
stuff,
excludeFilterDims:"[NOTES.OldestNoteDateOfVisit]",
stuff
});

 and it shold work. No leading brackets before the quotes start after the excludeFilterDims key.

Let me know.

hmm.. it still doesn't seem to work.

prism.jumpToDashboard(widget, {
drilledDashboardDisplayType:1,
displayFilterPane:true,
excludeFilterDims:"[NOTES.OldestNoteDateOfVisit]",
displayDashboardsPane:false,
displayToolbarRow:false,
displayHeaderRow:false,
drillToDashboardNavigateType:1,
dashboardId:"62fd12cc9162f000395da2cc"
});

 

hkkwon89_0-1661803240783.png

 

 

From JTD Technical Details page:

Note: When excluding the date dimension
using parameter excludeFilterDims,
(Calendar) must be used or the exclusion
will not
work. Example:[Table.Dimension(Calendar)]

I remembered reading this on the JTD docs. So, since you're excluding a date, try:

excludeFilterDims:"[NOTES.OldestNoteDateOfVisit(Calendar)]"

I haven't done this use case before, so let me know if that works. Play around with the syntax a little if need be.

sneak
8 - Cloud Apps
8 - Cloud Apps

Any luck with the last idea?

Hi Sneak,

It looks like you missed space in the dimension. The correct form is below:

[NOTES.OldestNoteDateOfVisit (Calendar)]

Another point - type of the variable "excludeFilterDims" is "array". So, the whole script will look like this:

prism.jumpToDashboard(widget, {
  excludeFilterDims: [
    "[NOTES.OldestNoteDateOfVisit (Calendar)]"
  ]
}

 

This worked!